Auto reposting with woocommerce

Forums SNAP – WordPress Plugin Forums Auto reposting with woocommerce

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #30081
    dreadedhamish
    Participant

    I’m trying to get my store to auto post an item every day.
    I’m using woocommerce. I’m not sure if woocommerce items are custom post types or custom pages etc…

    Products are not able to be reposted. The meta box is on the product page and everything is sent when a post is made. I’ve been making an item a draft and then publishing again to repost the item to all my networks.

    The product categories don’t show up when I click select categories to repost, and when I schedule a repost and save there the next post says it will occur “never”.

    Is there any way to make SNAP see woocommerce items as objects that can be auto-reposted?

    #30425
    NextScripts.com
    Participant

    This was fixed in 3.0.6

    #30435
    dreadedhamish
    Participant

    Amazing!

    Check updates, 3.0.6 ready, updated.

    #30460
    dreadedhamish
    Participant

    Getting closer – I can now select “products” as a category to post.
    But it still doesn’t autopost. Still last product posted was “never” and next is “never”.

    What should I try next?

    #30664
    dreadedhamish
    Participant

    It now working with products that I have repost (so if I put something into draft, then publish it again, it’s now able to be auto reposted.).

    I’ll try and figure out how else to get them all auto postable again.

    #318852
    Allan
    Participant

    Version 3.4.4 same problem.

    We have selected to repost “products” in the Advanced options, but when adding a new product we must manually select “repost.”

    Allan

    #323524
    Guy
    Participant

    I’m having the same problem. Has there been a fix yet?

    #323575
    NextScripts.com
    Participant

    It was fixed over a year ago. Activate “product” in a settings and will work.

    #372287
    stuart
    Participant

    i have ‘products’ set up in the auto post settings, however when new products are listed they are not being posted to Facebook – is this still an issue, and or what are the exact settings to ensure this now works?

    #504903
    alex
    Participant

    This is still not working. Has anyone found a fix for this?

    #505199
    Sherwick
    Participant

    I also have exactly the same problem and I have the Pro version too.

    Can someone at NextScripts please help?

    #518447
    ANDERSON FINGER
    Participant

    I managed to turn in the advanced settings NextScript/settings/Autoposting Filters/

    Inside of Post types, insert “product”…,

    Go for product and set

    #536910
    EgorStoletov
    Participant

    You need to add custom post type “Product” in “Settings’ page of SNAP.
    Please go to SNAP settings page -> Autoposting Filters -> Filter Posts (Only posts that meet the following criteria will be autoposted) -> Post Type, Post Format >>

    Checked Include (Post only …) and add to the field “Post Types (Posts, Pages, Custom Post Types)” post type “product”.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.