SNAP auto posting does not work. Only in manual mode.

Forums SNAP – WordPress Plugin Forums SNAP auto posting does not work. Only in manual mode.

Viewing 15 posts - 1 through 15 (of 24 total)
  • Author
    Posts
  • #557015
    zhora
    Participant

    Hi guys.
    I use SNAP for several years now. All settings have long been made and tested. But the problems started after the last update of the plugin.
    SNAP does not auto-post. And the log / history is crammed with such messages (every 3 minutes):
    “[2017-10-20 21:19:41] – [**WARNING. Unhealthy Cron Request**] [ [More info] ] – Too close (15.01s) to the previous one. Now – 21:19:41 | Previous – 21:19:26| Cron called from..”
    Post to send to social networks can only be done manually using the SNAP button “Post to All Checked Networks”.
    What is the problem I can not understand. Before that, everything worked well.
    Please tell me how to solve this problem?

    #557018
    mkt@oww.co.nz
    Participant

    I have the same issue.

    It just does not work when I schedule a blog post. The post goes live on my website but nothing happens anywhere else… no updates to any of my social media sites. This only happens since the new version upgrade. It does however work if I do post to the individual social sites manually.

    #557035
    blaivas
    Participant

    Same here.
    But I think the issue is when you set a Posting delay on Advanced account settings. If nothing is set up there, it works for me.
    That Advanced settings part is messed up and probably needs more work. For example, filters don’t work for me either.

    So try to autopost without any adjustments to Advanced settings

    #557053
    adobohamburger
    Participant

    Possibly, if you go under Settings and uncheck the [New! Improved!] Autoposting Filters option, everything you publish will autopost. Conversely, if you add a universal filter which will cover all of your posts, everything will autopost. After I filtered by author and included my name (mine is a single-author blog), autopost worked.

    Still no reply as to why there is no interface with options anymore on the “New Post” and “Edit Post” pages even though there are settings in User Privileges/Security to allow them. Not even in 4.0.6.

    #557057
    zhora
    Participant

    Thanks for answers.
    In the settings SNAP, I unchecked the “Filter Posts” checkbox. And autoposting started to work. But the post filter is disabled.

    Messages “[**WARNING. Unhealthy Cron Request**] [ [More info] ] – Too close” are permanent. SNAP offers to change the settings of WP Сron. But WP Сron is designed to operate the site and change its settings for one plugin is unreasonable. Hosting also uses the service WP Cron (Cron Tab). And this can lead to unpredictable results.

    The SNAP plug-in needs to be made normal. Because the plug-in has many functions that do not work: the global URL does not work and you need a separate URL for each social network, the filter posts has stopped working..
    I hope for new plug-in updates.

    #557058
    blaivas
    Participant

    I used this setup for that Unhealthy cron reques:

    WP-Cron: Scheduling Tasks in WordPress

    It took me half of the day to figure out how to make it work, but eventually it worked. I think other functions on site which are using Cron are working fine too. For example, automated emails are still coming through, so I guess Cron is working.

    But if I set, for example, 1 minute delay on the account, then that’s it, it doesn’t auto-post anymore… I hope they will fix this soon, as this is important part of the plugin which I need to use

    #557083
    blaivas
    Participant

    Sorry, it looks like I was wrong. Disabling Cron actually messed up my website, so this is not a good idea, but without that you will get that [**WARNING. Unhealthy Cron Request**], which means your posts won’t get posted.
    I think I’m done with this plugin, time to look for another one..

    #557084
    adobohamburger
    Participant

    Sorry, it looks like I was wrong. Disabling Cron actually messed up my website, so this is not a good idea, but without that you will get that [**WARNING. Unhealthy Cron Request**], which means your posts won’t get posted.
    I think I’m done with this plugin, time to look for another one..

    Post back if you find one and tell us what it is.

    #557086
    blaivas
    Participant

    https://codecanyon.net/item/accesspress-social-auto-post/11752265?ref=AccessKeys

    I’m now checking this one. Looks not bad, slightly less features, but they said they are going to add more on next update. No CRON issues and only costs $20 for premium version.
    However, I am having some other issues, like Filters not working, which I was having with Nextscripts plugin too. Probably something not right with my website

    #557090
    adobohamburger
    Participant

    https://codecanyon.net/item/accesspress-social-auto-post/11752265?ref=AccessKeys

    I’m now checking this one. Looks not bad, slightly less features, but they said they are going to add more on next update. No CRON issues and only costs $20 for premium version.

    Thanks, man! No one wants to have to take a wrench to their server to make a plugin work. I mean, that’s why they’re called “plugins”, right? Just plug them in and they work.

    #557110
    James
    Participant

    Anybody got solution on this, auto posting does not work on the latest version(4.0.7).

    #557111
    James
    Participant

    Ok, I found a solution, its not really a bug but rather an implementation. When you are an admin at the same time the author and editor the App will prevent you from posting because SNAP defaults to Administrator autopost only. It was implemented because there are many cases were an admin does not want to give permission for autopost to other user groups such as Editor or Author. But sometimes, the Administrator, the Author and Editor were the same user and the cant auto publish. Check the log and you will see that “User ID 2/3 not permitted to autopost” or the likes. To solve this, follow the procedures here

    https://www.nextscripts.com/2013/05/version-2-7-13-security-fix-caused-some-troubles/A

    If you would not want to read, just Go to “Settings” then give the user group permission to autopost.

    #557168
    zhora
    Participant

    This is crazy. Again, after the update, SNAP stopped working. SNAP makes auto-post only in Facebook, and does not do other social networks. SNAP autoposting in other of social network works only in manual mode.
    What is the problem again, there are ideas? ..

    #557169
    NextScripts.com
    Participant

    Please update to the latest version 4.0.10. This problem has been fixed there.

    #557172
    Forexflow
    Participant

    As I’ve replied on the other Cron post, today’s update has fixed the social media auto-posting. Thank you to the Nextscripts team for your hard work on this.

Viewing 15 posts - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.