500 error code with all my website use SNAP pro version (1.5.4)

Forums SNAP – WordPress Plugin Forums 500 error code with all my website use SNAP pro version (1.5.4)

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #558556
    nghiatgs@gmail.com
    Participant

    Today,
    I have 500 error code with all my website use SNAP pro version (1.5.4) .
    What happen with SNAP service ?

    #558557
    NextScripts.com
    Keymaster

    1. Please use the latest version which is 1.5.5. it does not have any issues.
    2. You are getting 500 error code with 1.5.4 because your PHP is EXTREMELY OLD. Please use PHP version that is currently officialy supported – PHP 5.6, PHP 7.0, PHP 7.1 or PHP 7.2. Your PHP version reached end of life quite some time ago.

    #558572

    I have the same issue. Yes, I understand what you are saying, but due to all the custom plugins, we are not able to make the changes just now. It cost alot to recode custom plugins running on PHP 5.3. We are just wanting the Pro version to work as it has before. Please write the code we need to permit PHP older versions. Or fix the method you are checking for license keys validity please.

    We still pay you the same, every year. So please make this happen. Thank you.

    #558573

    I update my ticket and asked you for a price. Thank you.

    #558574
    NextScripts.com
    Keymaster

    You REALLY should not be using PHP versions below 5.5

    PHP 5.3 and 5.4 have several very bad security issues that are not fixed and not going to be fixed, because they are no longer supported or updated.

    if you are familiar with WordPress please go to the database and delete row “__plugins_cache_242” from your wp_options table. Then please go to the Help/Support tab and click [Check for API Update].

    That will fix the issue.

    If you have issues with old plugins and PHP 7, at least try to upgrade to 5.6 or 5.5. They are not that different from 5.3 to cause any major compatibility issues.

    Upgrading old, slow, outdated, insecure PHP is a much better solution. 🙂

    #558580

    Okay, this has been fix. Here is the instructions given to me by Ludwig. This fixed the issue, and I was able to upgrade both the SNAP and Pro plugins to their current versions.

    “Please go to the WordPress database and delete row __plugins_cache_242 from your wp_options table. Then please go to the Help/Support tab and click [Check for API Update].”

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.