auto post to closed facebook group fails

Forums SNAP – WordPress Plugin Forums auto post to closed facebook group fails

  • This topic has 7 replies, 1 voice, and was last updated 7 years ago by jerome.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #449370
    dribber
    Participant

    Hi

    I am trying to setup an auto post from my site to publish events to a facebook closed group automatically.

    First I setup the closed group and a facebook app (type website). The app works fine for facebook connect.

    Then I installed SNAP and configured the group URL and the app ID & secret.
    Authenticated my user without a hitch.

    But submitting a test post fails with the following error:
    (#200) Insufficient permission to post to target on behalf of the viewer

    I don’t get it, my user is allowed to post in the closed group.
    For test purposes I created a new open group and I get the same error.

    Do I need to add more permissions to the app in order to do this?
    Currently only email, public_profile and user_friends are active. I did not submit the app since I only need it for login and posting, nothing else.

    And since I am authenticating my own FB user I thought that should be enough.

    Any help is greatly appreciated.

    #450330
    Ben
    Participant

    I’m having same problem
    Trying to send test post and get this:
    Array
    (
    [Warning] =>
    [Error] => Permissions error
    )
    Array ( [Warning] => [Error] => Permissions error )

    #454055
    Evgeny
    Participant

    Array ( [Warning] => [Error] => Permissions error )

    Worked and stopped

    #455539
    ronson
    Participant

    Same here,

    with the exact same error-message.

    It just works fine for a running fb-page.
    Now I wanted to change it to a fb-group (in which I am admin of course), but get this permission-error.

    Do I have to set up a new fb-app for that?

    Or why am I not authorized?

    TY!

    #455693
    NextScripts.com
    Participant

    You need to use numeric group URL and you need to re-authorize every time you are changing the value of the Facebook URL field.

    #457292
    Randize
    Participant

    I use numeric group URL, it works for public group but close group is giving me this error:
    [Error] [FB – XXX] – -=ERROR=- Array ( [Warning] => [Error] => Permissions error )

    Anyone can get their SNAP post to closed group?

    #457336
    Andy
    Participant

    I have exactly the same problem. This problem started like 15 minutes ago. I only use numeric group ids and I reauthorized every sigle FB account. i can post into my group, but not into groups where I am not the admin.

    #458491
    jerome
    Participant

    i am having same problem.. Using Numeric and still getting same result. Need help. thanks

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.