Can't post image on Facebook

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #31474
    Sam
    Participant

    I NextScripts Team,

    I’ve been struggling all day in order to make it work, but it just won’t.
    I’m making post on a WP blog containing only Featured Image and a title, nothing more.
    I would like to post just the image to my Facebook page, but what I’m getting is just the text I can set on SNAP, something like “New post (10891_645682748795801_1742648905_n) has been published on FB_page”.

    I have check ” Let Facebook fill the link info ” and when I check sources of my post, I can see
    <meta property=”og:title” content=”10891_645682748795801_1742648905_n” />
    <meta property=”og:url” content=”https://XXXX.com/?p=94&#8243; />
    <meta property=”og:site_name” content=”XXXX />
    <meta property=”og:description” content=”” />
    <meta property=”fb:app_id” content=”547004422050031″>
    <meta property=”og:image” content=”https://XXX/wp-content/uploads/2013/11/10891_645682748795801_1742648905_n.jpg”/&gt;

    Is there something wrong ? I don’t know much about all these OG meta and such.

    Hope you can help,

    Sam

    #31572
    NextScripts.com
    Participant

    What is your type of post?

    #31581
    Sam
    Participant

    ” Image Post – big image with text message” and “Post to Timeline”

    (Note that I already posted manually in order to create the album)

    #31583
    NextScripts.com
    Participant

    This type of post has nothing to do with OG tags.

    Do you have featured image set?

    Please try to come back to one of the existing posts and try to repost it. Will it work?

    Are you getting any errors?
    Please check your Log/History tab and let me know if you have any errors there.

    #31585
    Sam
    Participant

    Yes I have featured image set.

    If I go to existing post (with only text sent to Facebook page) and click “Repost” on the SNAP option, I’m getting the following error :

    Array ( [pgID] => [isPosted] => 0 [pDate] => 2013-11-14 01:13:03 [Error] => [ERROR] (#220) Application does not have the capability to make this API call
    )

    #31593
    NextScripts.com
    Participant

    Then it means something is not alright with your application. Please try to re-authorize it. It id doesn’t help, delete it and create and setup a new one.

    #31664
    Sam
    Participant

    I re-authorized the application.
    Then I tried to repost an existing post, and it worked.
    But if I make a new post, I’m getting again just text and no image posted. I have to go the my wordpress post and click “repost to facebook” in order to repost it with the picture.

    ANy idea ?

    #31673
    Sam
    Participant

    I got it to work by publishing as draft and then schedule draft to post.
    Thanks.

    #31723
    NextScripts.com
    Participant

    This means your image is not yet available at the time you make the post. You can simply delay autoposting to couple minutes: https://www.nextscripts.com/snap-features/scheduled-and-delayed-posting/

    #35824
    Honza
    Participant

    Hi, we didn´t work :/ Can you help us? 🙂
    https://www.facebook.com/SvetAndroida

    #35827
    NextScripts.com
    Participant

    @Honza what are you asking exactly?

    #35890
    Honza
    Participant

    Hi, yeah sorry.
    We use WordPress a autoposting all our link from https://www.svetandroida.cz/ to FACEBOOK, but from 14.11. we have problem with view images. All our image, which create in article (or link on website) is transformed from JPG to PNG and look only like a “grey nothing”…You can see on https://www.facebook.com/SvetAndroida
    Do you know, what is problem? I know that FB get update to picture view…

    #37218
    mach4
    Participant

    Can this problem be dealt with, you know yoke cause?

    #37288
    NextScripts.com
    Participant

    The answer is in the FAQ – #1.5:

    Support FAQ

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.