Can’t Posting to Facebook

Forums SNAP – WordPress Plugin Forums Can’t Posting to Facebook

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #573621
    Qazqer
    Participant

    Hello, today i have a problem with Facebook posting. I can’t publish my post to Facebook, i checked the log it says “Error Invalid username or password (401)|Failed Session 0”. I use Snap Premium Api with sesion login method follow the tutorial of Facebook Configuration. Please help me to solve this problem

    #575288
    proplah
    Participant

    have u solve this issue yet? i have the same problem

    #575959

    The problem has arisen due to a change in Facebook Policy. Apparently, now the developers of snap need to integrate the Facebook Login (https://developers.facebook.com/docs/facebook-login/web) in order to authorize users to use the app now. Regardless of whether your FB app has successfully completed the approval process with Facebook, it will now, no longer recognize your login.

    #576044
    NextScripts
    Keymaster

    kenancross, not really sure what are you talking about. “Facebook Login” is not relevant to SNAP at all.

    Quazqer, please create a new session and use it in SNAP.

    #576453

    Facebook login is quite relevant actually. From the developers at Facebook themselves, the method you’re using to authorize Facebook accounts isn’t passing their verification as using the official Facebook login. Even though my app is approved through facebook, since their latest security update as of 2 weeks ago, this plugin fails posting to Facebook every single time.

    #576509

    kenancross, please stop confusing people. “Facebook login” is an interactive feature. You manually need to login to FB from your browser using “Facebook login” and make a post. The whole idea for SNAP is to post WITHOUT user interaction. So we are not using “Facebook login” and we will not be using “Facebook login”. We cant make our users manually to login to Facebook every time plugin wants to make a post.

    SNAP is using parts of official API that allow posts automatically without user interactions and our Premium API also do just that.

    #576511
    Xeon11
    Participant

    Hello Forum

    I had the same error 401
    For me I solved it the following:

    Facebook has now the option, facebook.com – Account settings, to change to the new Facebook scheme including a dark modus. When doing that Nextscript posting error occurs.
    When switching Facebook back to the classic mode (white/blue) mode, postings are working.

    I have reported this bug via a ticket. No response received so far.

    • This reply was modified 2 years, 6 months ago by Xeon11.
    #577509
    sexoblogue.fr
    Participant

    Thank you very much for the tip! I had the same error message that had been displaying for a few days and I didn’t know what to do. While reading your post I remembered that I had switched” to the new version of Facebook a few weeks ago.
    I switched back to the old version of Facebook, and the post works again.

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.