New Pinterest Standalone API is not working.

Forums NextScripts API Forums – Google+, Pinterest, LinkedIn, etc.. New Pinterest Standalone API is not working.

  • This topic has 15 replies, 1 voice, and was last updated 7 years ago by Felix Futuri.
Viewing 15 posts - 1 through 15 (of 16 total)
  • Author
    Posts
  • #213680
    Yagmur Akgün
    Participant

    So, no one is bothering answering my support tickets, I’ll just post here. In the example for Pinterest Standalone API there is a call for nxs-api.php:
    require_once “nxs-api/nxs-api.php”;
    which is not included in the API library zip.
    There is a file called nxs-http.php though, so I changed my script to reference this file.
    My script for testing looks like this:
    <?
    require “postToPinterest.php”;
    global $nxs_gCookiesArr;
    $nxs_gCookiesArr = doCheckPinterest(); // Use your function to retrieve saved data to array
    $email = $argv[1];
    $pass = $argv[2];
    $msg = $argv[3];
    $imgURL =$argv[4];
    $link = $argv[5];
    $boardID = $argv[6]
    $loginError = true;
    if (is_array($nxs_gCookiesArr)) $loginError = doCheckPinterest();
    if ($loginError!==false) {
    $loginError = doConnectToPinterest($email, $pass);
    }
    if (!$loginError)
    {
    doPostToPinterest($msg, $imgURL, $link, $boardID);
    } else echo $loginError;
    ?>
    So, since changing to the newest API library (because login was broken in the old one), I am getting this error:
    PHP Notice: Undefined index: SERVER_NAME in C:\php\nxs-http.php on line 188
    nxs_Error Object
    (
    [errors] => Array
    (
    [http_request_failed] => Array
    (
    [0] => SSL certificate problem: unable to get local issuer certificate
    )
    )
    )
    – ERROR
    I am running this script on localhost, which worked well until this new update.

    #213723
    NextScripts.com
    Participant

    The answer is in the FAQ – #4.4:

    Support FAQ

    #214416
    Madni Nadeem
    Participant

    API problems need to be fixed as we are lookoing forward to more services too.
    Really wanted to see Reddit in the list of services provided.

    #215113
    David
    Participant

    The response seems to be referring to SNAP Pro for WordPress. I also need help configuring the stand alone SNAP API. I feel like everything on this site refers back to the WordPress product. I cannot authorize my Facebook accounts with the Facebook API. Please help! Where should I go to get more help with the stand alone API? I am able to add Facebook accounts no problem (as far as the settings in place), but every time I try to authorize an account, it will not work.

    #215151
    Toni
    Participant

    The standalone Pinterest API doesn’t work anymore. It worked fine until yesterday but now I get the following error:
    [api_error_code] => 7
    [message] => You don’t have permission to edit that board.
    [code] => API_ERROR
    [target] => <webapp.resources.pin_resource.PinResource object at 0x1ab05e90>
    [http_status] => 401

    Please note I use the latest version of Universal SNAP API

    #215271
    NextScripts.com
    Participant

    David. it doesn’t matter WordPress pluing ir standalone API. SSL must be working.

    Toni. This error comes out only if you supply incorrect board ID. Please check that you have the correct one.

    #216884
    Luke
    Participant

    I have the exact same problem. I have redownloaded the standalone api and it’s still the not working.
    The API result is “1” so I can’t even submit an error report. This is rather frustrating. I tested the demo on your site and it’s working. So what’s wrong?

    #217370
    Toni
    Participant

    I’ve downloaded the latest version and now I get the following error:
    Fatal error: Call to a member function getHeaderValue() on a non-object in nxs-http.php on line 88

    #220623
    NextScripts.com
    Participant
    #220830
    Toni
    Participant

    I’ve downloaded the latest version and now I get no errors but nothing is posted on Pinterest

    #221521
    Jaco Roux
    Participant

    I get a false response from the API, after doing a bit of debugging, this is what Pinterest returns:

    Any suggestions:

    array(
    ‘page_info’ => array(
    ‘breadcrumbs’ => array(),
    ‘meta’ => array(
    ‘og:url’ => ‘https://www.pinterest.com&#8217;,
    ‘description’ => ‘Pinterest is a visual discovery tool that you can use to find ideas for all your projects and interests.’,
    ‘pinterest’ => ‘nohover’,
    ‘og:type’ => ‘website’,
    ‘og:description’ => ‘Pinterest is a visual discovery tool that you can use to find ideas for all your projects and interests.’,
    ‘twitter:app:android’ => ‘com.pinterest’,
    ‘twitter:app:id:ipad’ => ‘429047995’,
    ‘og:title’ => ‘Pinterest’,
    ‘twitter:card’ => ‘summary’,
    ‘twitter:site’ => ‘@pinterest’,
    ‘og:image’ => ‘https://passets-ec.pinterest.com/images/about/logos/Pinterest_Favicon.png&#8217;,
    ‘twitter:app:id:iphone’ => ‘429047995’
    ),
    ‘title’ => ‘Pinterest’
    ),
    ‘client_context’ => array(
    ‘app_version’ => ‘1a8199c’
    ),
    ‘request_identifier’ => ‘404532234559’,
    ‘module’ => array(
    ‘html’ => ‘<div class=”ajax CsrfErrorPage Module” id=”CsrfErrorPage-1″>
    <div class=”errorHeader”>
    <div class=”errorMessage”>
    <div class=”errorInternal”></div>
    <div>Uh oh! Something went wrong.</div>
    <p class=”retry”>Try these little browser tricks to get going again.</p>
    </div>
    </div>

    <ul class=”diagnoseList”>
    <li class=”diagnose”>
    <span class=”errorNumber”>1</span>
    Turn on Javascript
    <li class=”diagnose”>
    <span class=”errorNumber”>2</span>
    Clear your cache and cookies
    <li class=”diagnose”>
    <span class=”errorNumber”>3</span>
    Make sure you’re up-to-date
    <li class=”diagnose”>
    <span class=”errorNumber”>4</span>
    Try a different browser

    <p class=”more”>
    Still having trouble? Get help.</p>
    </div>’,
    ‘tree’ => array(
    ‘resource’ => null,
    ‘name’ => ‘CsrfErrorPage’,
    ‘children’ => array(),
    ‘deps’ => array(
    (int) 0 => ‘CsrfErrorPage’
    ),
    ‘errorStrategy’ => (int) 2,
    ‘attributes’ => array(
    ‘class’ => ‘ajax CsrfErrorPage Module’,
    ‘id’ => ‘CsrfErrorPage-1’
    ),
    ‘options’ => array(),
    ‘uid’ => ‘CsrfErrorPage-1’
    )
    ),
    ‘resource_response’ => array(
    ‘data’ => null,
    ‘error’ => null
    )
    )

    #222924
    Er0s
    Participant

    The atandalone API for pinteres is not working, when are you going to fix it?????

    #223038
    Toni
    Participant

    An update has been released and it looks like it’s working now

    #423406
    thien
    Participant

    Problem:

    Array ( [pgID] => [isPosted] => 0 [pDate] => 2015-05-05 16:43:08 [Error] => Something went wrong – Array ( [api_error_code] => 7 [message] => You don’t have

    API Version: API Version: 2.16.3
    Plugin version: 3.4.16

    #460785
    Felix Futuri
    Participant

    I get the “you don’t have access to edit that board” error on one of my sites, but on another one it posts just fine.

    Very strange because I imported the settings from one to the other, and the names of the boards are completely different.

    One the one site that doesn’t work, I even switched to new boards, created new boards, nothing fixed it. Is there a solution? It’s strange that one works and the other doesnt.

Viewing 15 posts - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.