Pinterest API broken ?

  • This topic has 16 replies, 1 voice, and was last updated 8 years ago by AndrewTerprovs.
Viewing 15 posts - 1 through 15 (of 17 total)
  • Author
    Posts
  • #1118
    KenAddams
    Participant

      Hi All,

      I was using the Pinterest API in a PHP script and it was working very well till last week. Now I got an error rmessage “Incorrect username / password” when I try to connect.

      I tried to update postToPinterest.php file API with last version : 2.2.14 (Oct 09, 2012), but no change.

      Note that I didn’t changed anything to my piece of code, I always connected with my email and password using the code below and it was working fine.

      echo ” . Sending update to Pinterest…\n”;
      require “postToPinterest.php”;

      $email = ’email@mydomain.com’;
      $pass = ‘xxxxxx’;
      $msg = $content;
      $imgURL = $thumbnail;
      $link = $permalink;
      $boardID = ‘my_board_id’;

      $loginError = doConnectToPinterest($email, $pass);
      if (!$loginError)
      {
      echo ” – Msg = $msg\n”;
      echo ” – imgURL = $imgURL\n”;
      echo ” – link = $link\n”;
      echo ” – boardID = $boardID\n”;
      doPostToPinterest($msg, $imgURL, $link, $boardID);
      } else echo $loginError;

      Any idea ?

      #1148
      Faith
      Participant

        Same here. I thought at first I had hit a rate limit, but after testing from several IP addresses and using different accounts, it seems to be broke across the board.

        #1275
        Faith
        Participant

          Still no answer to my support ticket I put in several days ago, so I guess this product will remain broke with no fix.

          #1290
          MS
          Participant

            I don’t think the product is broken. I purchased the API (ver 2.2.14) couple days ago and it works perfectly.

            Try to open postToPinterest.php, find the function doConnectToPinterest and find the row saying

            //## ACTUAL LOGIN

            uncomment the following on the next row.

            echo $fldsTxt; prr($contents); die();

            Try your script.

            This will give you more info about your error.

            Michael.

            #1386
            KenAddams
            Participant

              Hi,
              Thank you for your answer.
              Here is the error message I got. Am I the only one have this one ?

              Forbidden (403)
              CSRF verification failed. Request aborted.

              You are seeing this message because this HTTPS site requires a ‘Referer
              header’ to be sent by your Web browser, but none was sent. This header is
              required for security reasons, to ensure that your browser is not being
              hijacked by third parties.

              If you have configured your browser to disable ‘Referer’ headers, please
              re-enable them, at least for this site, or for HTTPS connections, or for
              ‘same-origin’ requests.

              Thank you for your help,
              Ken.

              #1395
              Faith
              Participant

                Tried this too and seeing the same error message as above.

                #1419
                NextScripts.com
                Participant

                  Are you sure you are using ver 2.2.14? Because the only difference between 2.2.14 and the previous version was the fix for that problem.

                  Also make sure you are loggin in with your email, not your username.
                  See here: https://www.nextscripts.com/blog/changes-for-pinterest-login-process-immediate-action-requred/

                  #10066
                  Scott
                  Participant

                    Has there been any resolution to this? I’m consistently seeing Incorrect Username/Password and I’m confident my UID/Pass is correct.

                    #10079
                    NextScripts.com
                    Participant

                      Pinterest API is working fine. Please contact support directly, we will take a look at your site

                      #10692
                      Kenaddams42
                      Participant

                        Hi !
                        Looking at the code of postToPinterest.php, it seems the “UserNav” string is not found in the loaded page, so the following test fails and returns “Incorrect Username/Password”.

                        if (stripos($contents, ‘UserNav’)!==false){ //echo “You are IN”;

                        Having consulted the content of the returned page with the following code, I confirm I am correctly logged in.
                        echo $fldsTxt; prr($contents); die();

                        So where is the problem ??

                        Best regards,
                        Ken.

                        #10724
                        NextScripts.com
                        Participant

                          What version of the Pinterest API do you have?

                          ‘UserNav’ was used for the old pinterest interface. It won’t work if you have switched to the new one.

                          Please download the latest version of the API.

                          #10775
                          Participant

                            Hi,

                            I converted my pinterest page to a business one and the pinterest posting script seemed to immediately stop (noticed hours or days later, not sure).
                            I fixed the script (issue related to ‘UserNav’) but a few days later – which is today – the script stops working again. is it the new look that is to blame?

                            it seems to be 502 error. using latest version 2.6.0 (Mar 12, 2013)
                            I have checked and am logged in.

                            #10890
                            NextScripts.com
                            Participant

                              2.6.0 works fine with old look, new look, personal accounts and business accounts. Please contact us directly if you would like us to take a look at your environment.

                              #14555
                              Peter OUdenes
                              Participant

                                Hello,

                                Using the plugin SNAP in my wordpress website to push my blogs to several social media sites.
                                Only pinterest is not working. My Username/Password are correct, it can connect because i can receive the board list. But it will not send a test message i get error: Pinterest Returned Error 502

                                Can somebody support me?
                                Thanks

                                #14556
                                NextScripts.com
                                Participant

                                  Go to the https://www.nextscripts.com/support and open support ticket.

                                Viewing 15 posts - 1 through 15 (of 17 total)
                                • You must be logged in to reply to this topic.