Problem with schedule autopost and cron

Forums SNAP – WordPress Plugin Forums Problem with schedule autopost and cron

Tagged: 

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #558317
    wictor
    Participant

    Hello. I sent ticket more than 10 days ago.
    I showing part of my ticket here

    *****************************************************************************************************************
    I have a problem with Cron on my website1.
    I’m turn on “Use WP Cron to Schedule autoposts” on “How to make auto-posts?” on SETTINGS TAB and choose interval for Twitter(example) accounts.
    But Cron doesn’t work.
    Publish Immediately works good.
    Tried to configure Cron with these help article http://www.nextscripts.com/tutorials/wp-cron-scheduling-tasks-in-wordpress/
    But it doesn’t help. And tech support of hosting also couldn’t help with it. They said that on their side everything good, write to developer.
    =====================================================
    The first time the key was activated on website2.
    On my website2 plugin works good and Cron also. But on others websites doesn’t work.
    I almost find problem.
    On website2 Cron works and after activated plugin at DB->wp_options->option_name->cron appear string like this
    ===========================================================================================================================
    a:1:{s:19:“nxs_querypost_event”;a:1:{s:32:“40cd750bba9870f18aada2478b24840a”;a:3:{s:8:“schedule”;s:8:“nxsquery”;s:4:“args”;a:0:{}s:8:“interval”;s:2:“60”;}}}
    ============================================================================================================================
    On website1 and others websites where Cron doesn’t work this string absence at DB and Schedule autoposts doesn’t work.
    ============================================================================================================================
    Also I installed “Advanced Cron Manager” on website2 and I see that “nxs_querypost_event” cron task works every 1 minute.
    On anoters websites (include website1) in the plugin “nxs_querypost_event” cron task absent.
    ===========================================================================================================================
    Plus on HELP/SUPPORT tab after click on the link “Show Cron Test Results” on website2 I have good results of Cron but on the website2 or anoters website I have result:
    “Check is not started yet… Please RELOAD this page in couple minutes.
    If you still see this message after several minutes, your cron is NOT RUNNING”
    ************************************************************************************************************************

    Please help
    Best regards.

    #558327
    ru
    Participant

    Hi,
    The same is happening to me… I filled a ticket and also a post here: https://www.nextscripts.com/forums/topic/not-cron-tasks-are-being-generated/
    Did you manage to fix this? Hope we have a solution soon…

    Thanks.

    #558332
    ru
    Participant

    Finally I managed to solve this.
    The problem that the cron event “nxs_querypost_event” (which is the one that activates de autoreposter) didn’t exist, so I had to create it. It’s easy to create cron events with the plugi Wp-Crontrol.
    Also, my theme (ionMag) was blocking the non-default cron-scheuldes (I could only select every hour, day, week or month), so I has to change to another theme so I could scheulde the event every 15 minutes.

    SOLVED.

    #558335
    sonofnet@gmail.com
    Participant

    I have the very same problem. And I thought that wordfence plugin was blocking it.

    Finally I managed to solve this.
    The problem that the cron event “nxs_querypost_event” (which is the one that activates de autoreposter) didn’t exist, so I had to create it. It’s easy to create cron events with the plugi Wp-Crontrol.
    Also, my theme (ionMag) was blocking the non-default cron-scheuldes (I could only select every hour, day, week or month), so I has to change to another theme so I could scheulde the event every 15 minutes.

    SOLVED.

    RU, how did you discover that nxs_querypost_event didn’t exist? And how did you find out that your theme was blocking cron schedules?

    #558339
    ru
    Participant

    Hello,
    Just find out those two things on internet, I don’t remember where… With the plugin called “WP-Crontol” you can see the on-going tasks on your WP-Cron. Look if “nxs_querypost_event” is there or not. If it’s not, try toc reate it: just put that name and that’s all you need to create it. No code.
    If it gives problems to you (like you can’t create it or you can’t adjust a 60 seconds interval) try to do it changing your theme to one of the defaults from WordPress.

    #558341
    sonofnet@gmail.com
    Participant

    Awesome! Thanks!

    #558372
    ahsan
    Participant

    I have the very same problem. And I thought that wordfence plugin was blocking it.

    Finally I managed to solve this.
    The problem that the cron event “nxs_querypost_event” (which is the one that activates de autoreposter) didn’t exist, so I had to create it. It’s easy to create cron events with the plugi Wp-Crontrol.
    Also, my theme (ionMag) was blocking the non-default cron-scheuldes (I could only select every hour, day, week or month), so I has to change to another theme so I could scheulde the event every 15 minutes.

    SOLVED.

    <span class=”et_quote_sign”></span>

    RU, how did you discover that nxs_querypost_event didn’t exist? And how did you find out that your theme was blocking cron schedules?

    Any settings to make the existing theme work? I don’t want to change the theme, wondering what needs to be done to get this working.

    #558374
    ru
    Participant

    There are plugins (like WP-Crontrol) where you can see all the cron tasks going on on your WordPress. I discovered that my theme was blocking the cron task deactivating it and activating one of the default themes.
    In my case I had no problem using another theme, but what I could only do would be to talk to the theme author.

    #559875

    Hello,

    The cron does exist in mine but it’s still not scheduling. Infact, i can see the cron working in SNAP cron logs file settings page

    Any idea on how to detect what is stopping nextscripts from scheduling and saying my cron is not functioning properly?

    #559912
    Der-Bank-Blog
    Participant

    I have the same prolbem. Log tells that a post is queried but the query remains empty

    #559957
    NextScripts
    Keymaster

    Do you have WP Cron setup correctly?

    WP-Cron: Scheduling Tasks in WordPress

    Please go to the Log/History page and check only “All Cron Events” checkbox.

    You should see ONLY crons executed from WGET or Mozilla every one or two minutes. If you see nothing at all, calls from “WordPress/4.x.x” or calls made at irregular time intervals, your cron is not set correctly.

    #559961
    Der-Bank-Blog
    Participant

    The cron is setup correctly. There are no cron errors at all

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.