Scheduled Posting w/WP CRON Still not working…

Forums SNAP – WordPress Plugin Forums Scheduled Posting w/WP CRON Still not working…

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #25602
    Alex V
    Participant

    I have updated to the latest BETA version just released (because the developer told me over email to please update to the latest), but still I cannot get scheduled autoposts to work to ANY of my networks.

    Here is a screenshot of my settings…

    https://cdn.mailsecure.us/SNAP-Settings.jpg

    I have checked with my host (it is managed WordPress via Dreampress over at Dreamhost and they can change virtually ANYTHING I need to on the server).

    They have pulled the access log for WP-CRON and it is firing no problem, so I know for certain wp cron is not broken on the server.

    The server time is set via NTP to Pacific Time

    I do not see ANYTHING in the log files now for SNAP after this new BETA release… all it shows is this…

    https://cdn.mailsecure.us/SNAP-Log.jpg

    The log used to be filled with all sorts of entries, but now after this release, it barely shows anything.

    I have emailed in for support over 9 times now, and NOW I have emailed in and offered to actually PAY ad hoc a fee for the developer to please come take a look at my setup and just fix what is wrong. I am not a very technical person, but I am trying here… and I REALLY NEED the autoposting/scheduled WP CRON function to work, otherwise my entire business model is shot. I NEED to be able to drip feed autoposts into Pinterest. Without that function, I am dead in the water right now.

    I am not sure why they are non-responsive right now and won’t help me. I have written a lot of emails by now, so I can only assume that they are too busy to help or it’s not worth their while money-wise. fine. I understand that. Developing is hard sometimes.

    But now I am offering to pay additionally… and hoping for a response.

    Please let me know. I am getting desperate and need this to work.

    Thank you. (I am chronicling a chain of my previous posts/thread below)

    ####PREVIOUS POSTS####

    Can’t seem to get scheduled posts to occur using WP CRON settings here…

    https://screenpresso.com/=2uSme

    Log reads these but no posts occur…

    https://screenpresso.com/=khyje

    I checked my wp-cron.php file, and all looks to be ok by me, plus I am on a specially design ‘for WordPress’ type of VPS by Dreamhost called DreamPress where they will literally customize ANYTHING for me I need,… so I just need to know what to tell them to change to make this work.

    NONE of my autoposting occurs. To any network. Only the immediate setting will work right now. I have emailed Ludwig back like 8 times now, but I think support is totally ignoring me for some reason – not sure why, as I feel as if I have been totally understanding of their time and flexibility on this… Once again,… I am on a managed, specialized VPS server setup specifically for WordPress, and my host will do almost ANYTHING I ask them to do as far as customization,… I just need to know from NextScripts WHAT to do. If it is an issue my WP-CRON or what? Is it broken? DreamPress/Dreamhost support is telling me WP CRON is fine and setup proper. Not sure who to believe. Getting very frustrated because I NEED the scheduled posting function to work, particularly for Pinterest… 🙁

    HELP.

    ANYONE. SUPPORT. WHOMEVER.

    HELP.

    guess I’ll keep posting and sending nice emails to Ludwig every day until someone can help out.

    :/

    thnx

    October 10, 2013 at 10:18 pm #25456

    Alex V

    Oh, and incidentally, my managed host guys just ran this output from the access logs that shows that wp-cron is in fact working…

    19 /pin/7922/
    24 /wp-content/themes/es-voguish/font/fontawesome-webfont.eot
    38 /wp-content/themes/es-voguish/font/fontawesome-webfont.ttf
    90 /pin/12092/
    130 /
    138 /wp-content/themes/es-voguish/favicon.gif
    138 /wp-content/themes/es-voguish/font/fontawesome-webfont.woff
    259 /xmlrpc.php
    888 /wp-admin/admin-ajax.php
    1107 /wp-cron.php

    with a LOT of accessing being made to it, presumably this is SNAP trying to do its business, but failing for some reason…

    Also, my server time is set via NTP to Pacific Time (where my hosting company resides in California), could that be an issue?

    again, any help appreciated…

    A

    #26854
    avet
    Participant

    Scheduled Posting in my site is not workin too. cron is running. all accaunts is on shedule mode.
    where i must do something ? thanks.

    #27545
    sonny
    Participant

    any solution on u ?
    my case worst, none scheduled also turn to scheduled than rest there … i wondering why ….
    wp cron definitely work…..

    #27799
    Mustafa
    Participant

    I am using multidatabase setup. But in both cpanel cron and wordpress cron, scheduled works gives password errors.

    But when I choose publish immediately all works.

    I also need help. 🙁

    Regards,
    Mustafa

    #27934
    Mustafa
    Participant

    Any help about this matter? Please…

    #28065
    NextScripts.com
    Participant
    #28251
    Mustafa
    Participant

    I have already done that. Still getting errors when I select scheduling.I have opened a ticket about this matter a few days ago.

    #28262
    sonny
    Participant

    this is what i really hate …..
    when we have question, support post FAQ ? wtf with this ? we ain’t spoon feed, we read but can’t get solution but support ain’t doing any help at all ….

    #230999
    Hil
    Participant

    Ludwig, I am having the same problem. I have setup the “Do not autopost more then one post per network every 1 hour” . What happens in relity is that all posts show up at the end of the “1 hour”. I also specified “Randomize posting time ± 45 minutes” but that does not help either. In short the posts will not not drip feed. I have 6 websites and each site uses Netscripts to post to atleast 5 Social networks each. Which is about 30 accounts. I am seeing the same behaviour across all accounts.

    I went through the link that support sent (as above) about wpcron and the cron jobs. What I do not understand is if netscripts isstaggering the jobs apart (for example 45 minutes) then why is cron job not following the task and “posting them in +/- 45 minutes” or “one post in 1 hour”. maybe a seperate cron task needs to be setup for each post, so that wordpress can drip feed it correctly

    You have helped me in the past and I hope you can do it again. We really need your help with this one
    Thanks

    #557119

    I have the same problem…. I set the “Do not autopost more then one post per network every” 45 minutes, but the 45 facebook account does publish the post all at once, then facebook blocks my account….

    If I configure Do not autopost more then one post per network every:45 minutes, it should publish faacebook #1, then, and 45 minutes later, facebook#2, adn 45 minutes later facebook#3 and so on…. Doesn.t?

    #557142
    rob@crio.nl
    Participant

    I have the same problem. Scheduled posts aren’t posted to Social Media (Facebook) and I see nothing in the log. If I manually publish a post it does work and I see the status of the Social Media accounts in the log.
    I’m using NextScripts: Social Networks Auto-Poster 4.0.8 and NextScripts: SNAP Pro Upgrade Helper 1.4.4.

    Disabling WP-Cron and setting up my own cronjob in DirectAdmin doesn’t work either, I see my own cronjob does run OK in the log though. The scheduled post is published but SNAP plugin doesn’t do a thing.

    #557148
    Forexflow
    Participant

    I have a similar issue also. I have Twitter and FB set to auto-post but as of this morning, only FB is auto-posting and twitter isn’t. Using the manual “post now” button works fine for TWT, as does a test tweet by my developer from the Snap settings.

    Through trial and error, it seems that the plugin is only allowing an auto-post to one social media account, as I’ve just tried a post with TWT auto-post ticked, and FB unticked. That worked to twitter but when I tried again with both ticked, only FB posted.

    I’m also wondering if something has gone awry from the overnight change in Twitter from 140 characters per tweet to 280?

    Any help would be greatly appreciated.

    #557171
    Forexflow
    Participant

    I’d like to report that the latest update today has now fixed the posting issue and my blog posts are now auto-posting to all my social media channels.

    Thank you to the developers who have been working on this. Great response and service.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.