Snap Pro – Unable to post to FB – (#200) Requires publish_stream permission

Forums SNAP – WordPress Plugin Forums Snap Pro – Unable to post to FB – (#200) Requires publish_stream permission

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #557022
    blaivas
    Participant

    I don’t know what happened, probably because I have updated Autoposter to the latest version.
    Whenever I am trying to post to Facebook groups, I get this message “Array ( [Warning] => [Error] => (#200) Requires publish_stream permission )”

    Account is admin (but not owner) in these groups and authorized in the plugin, so what other permissions are required? Perhaps Facebook changed some permissions?

    Also, I am still having issues with Filters – they don’t work! I have disabled all other plugins, I have removed all additional codes from functions.php, it still don’t work. Is there any way to debug and find out what is the problem?

    Plugin Version: 4.0.4 [Pro]
    (One User, Multiple Accounts)
    API Version: 4.0.24 [ID:18381]

    #557025
    blaivas
    Participant

    So I have found out this permission is deprecated, probably hat’s why it doesn’t work.
    https://stackoverflow.com/questions/46823605/200-requires-publish-stream-permission

    Any fix?

    #557028
    blaivas
    Participant

    I have also tested it on 3.84 version. I have even created new Facebook accounts to test it. Still the same error below. Can’t post to Facebook groups. Also, tried to post to Facebook page with Admin rights, getting error as I would have no rights. I am guessing Facebook has changed something.. And FB is my main soc network for this plugin, so I am guessing I can forget using Snap, because I barely get any support here…

    Testing …

    Array
    (
    [Warning] =>
    [Error] => (#200) Requires publish_stream permission
    )

    Array ( [Warning] => [Error] => (#200) Requires publish_stream permission )

    #557030
    NextScripts.com
    Participant

    Please just follow our very detailed and illustrated with many screenshots step-by-step instructions:

    Setup/Installation: Facebook – Social Networks Auto-Poster

    #557031
    blaivas
    Participant

    Ok I have found out what was the problem, unfortunately not from your “help”. Facebook was messing with my app, had a temporary locked down on my poster account. Which also made me question – why? Do we get lock-downs using this plugin?

    Your plugin is good (or would be if it would work as described), but the support is horrible. Waiting days or weeks for help and just to get the absolutely pointless answer… Don’t you think that I have already read through the documentation, as I had it already working earlier?

    Anyway, I have sorted out the Publishing issue, but my main issue is still on – Filters do not work like they should! I have tried all kinds of variations, tested it maybe 100 times or more and I still don’t understand this random pattern. It posts to some accounts, but doesn’t post to others, even if my filter is set up to post to all of them. Or if I set to NOT POST to the particular accounts, it still posts to them or skips them all. And other way around..

    Can you please give me your email address and I will make a clone site with admin rights for you to check and see it. It’s been ages since I first asked for help with this Filters issue and so far all I had from you was the statement that you don’t have time for this. Well, I have bought this plugin to use it and I would like to not waste yours or my time with these issues, but it doesn’t work!

    #557032
    blaivas
    Participant

    Ok I know you won’t spend 5 minutes to connect to my website, but please at least take a look at these pictures:

    I have posted 2 identical jobs one after another through 3 different accounts (2 fb and 1 twitter). 1 fb and 1 twitter account set to post with both Job packages, 1 Fb account set to post only with Basic Job package. The only difference between two Job posts there was that first one had 1 minute delay for both FB accounts set up on settings. I took it off posting the Job second time.

    So for some reason the delay was not 1 min, but 27 min?!? Jobs were delayed, but they did get posted first time, but not the ones with the right packages. One of them was supposed to be skipped. And the one which got skipped was supposed to get posted.
    And second time posting all jobs were skipped completely, but 2 of them were supposed to get posted…

    So what the hell?

    Log / history

    First account settings

    Second account settings

    Third account settings

    #557164
    t@justravis.com
    Participant

    I’m getting the same #200 error. I don’t see any indication of Facebook locking down my app.

    How did you find that out?

    Suggestions?

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.