Twitter auto publish not working on first go

Forums SNAP – WordPress Plugin Forums Twitter auto publish not working on first go

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #239381
    Bruce Paul
    Participant

    So the twitter auto publishing is acting strange for me and the searching that I’ve done on this forum hasn’t fixed the problem.

    I’m attempting to do this with a custom post type, the auto posting for twitter is by default no selected. If I create a new post and select to publish it to Twitter it won’t publish. After the post has been created, if I click repost, everything is fine.

    On the other hand, if I have it set to automatically post to twitter by default, it will work the first time through upon first publishing the post.

    Lastly, I have it set to publish immediately and not using wp cron.

    Here are my logs:
    (post to twitter by default) [2014-08-18 21:25:41] – [Posted] [Twitter – DHN Clones] – OK – Message Posted | PostID: 1100 – as |im | Post Link
    (post to twitter NOT by default) [2014-08-18 21:25:41] – [Skipped] [Facebook (dhn)] – -=[Unchecked Account]=- – PostID:1100
    (post to twitter NOT by default)[2014-08-18 21:25:41] – [Start =- ]- ——=========#### NEW AUTO-POST REQUEST PostID:(1100) Immediate ####=========——
    (post to twitter NOT by default)[2014-08-18 21:25:41] – [*** ID: 1100, Type: clone_drops]- Status Changed: draft_to_publish. Autopost requested.
    (repost to twitter after the post has been already been published) [2014-08-18 21:24:45] – [Posted] [Twitter – DHN Clones] – OK – Message Posted | PostID: 1098 – asdf |aj | Post Link

    #239815
    NextScripts.com
    Participant

    “Unchecked Account” simply means that checkbox in front of the account was not checked at the time you hit the “Publish” button.

    Please make sure it checked. Some functionality like excluded category, could auto-uncheck it.

    #239911
    Bruce Paul
    Participant

    It is checked when the post is published, which I think you can see by “#### NEW AUTO-POST REQUEST PostID:(1100) Immediate ####”

    There is not excluded categories or anything like that.

    #239913
    Bruce Paul
    Participant

    Also, I’ve enabled it to send me the error log if there is an error and I’m not receiving any email.

    #239954
    NextScripts.com
    Participant

    There is nothing that could cause “Unchecked Account” message other then unchecked checkbox in front of the account.

    #240099
    Bruce Paul
    Participant

    What do you mean in front of the account?

    Twitter is not checked in the settings page to auto post, but is selected when I click “publish post.”

    #240101
    Bruce Paul
    Participant

    And when that option is selected, to auto post from twitter, it posts to twitter on publish fine.

    #240170
    NextScripts.com
    Participant

    So what is the problem? If it’s selected (checked) it is posting fine, if it’s unselcted (unchecked) you get the “Unchecked Account” message.

    #240287
    Bruce Paul
    Participant

    In the settings page, I leave it unchecked as I don’t want every post to automatically be selected to post. The user wants to manually select it for each post before they publish. Thus, it’s currently not checked in the settings page, but when you select on the individual post, it is not posting to twitter when the post gets published.

    #242570
    Bruce Paul
    Participant

    any help?

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.