Won't find existing posts.

Forums SNAP – WordPress Plugin Forums Won't find existing posts.

  • This topic has 9 replies, 1 voice, and was last updated 9 years ago by Scott Purcell.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #180070
    Colin Poole
    Participant

      Hey all,

      So currently I believe I have a fully functioning WP_Cron (I use other scheduled events like backup of WP files etc, and have a Cron plugin that shows scheduled Cron tasks which have been executing fine) and I think once I can get the plugin to LOCATE my posts it may work correctly, but I have two issues.

      1: No matter how I set up the conditions for existing posts, “total posts included in reposting” is always “0”.
      2: Since any searches on that issue lead to cron warnings on your Troubleshoot section, I try the “Show Cron Test Results” and just get “Check is not started yet… Please reload this page in couple minutes.” and as I mentioned before, I already have other items running as expected using wp_cron.

      Hope for guidance, and as another member mentioned, I too would pay for premium support!

      Colin Poole

      #182708
      Alessio
      Participant

        Same problem for me: “No matter how I set up the conditions for existing posts, “total posts included in reposting” is always “0″.”

        All tests run fine: cron test ok, test posting to facebook ok, manual posting is ok…

        …but i can post with autoreposting.

        I have installed the last version of the plug in (3.3.3) on WordPress 3.8.2.

        Here the log:

        [2014-04-10 21:55:26] – [RE-Posting] [Facebook – Goodvibes.it] – (Nothing to Repost. – End of Query – Resetting) | Requested Time: 2014-04-10 21:55:15 | Current Time:2014-04-10 21:55:26 | | Last Time:2014-04-10 21:44:49 Next Time – 2014-04-10 22:04:43) | Reposting (Old to New) | Total posts included in reposting: 0 |
        [2014-04-10 21:45:30] – [Posted] [Facebook – Goodvibes.it] – OK – Message Posted | PostID: 1748 – Forse il vero grande segreto… |aj | Post Link
        [2014-04-10 21:44:49] – [RE-Poster] [Facebook – Goodvibes.it] – Initialization – First post will be: 2014-04-10 21:55:15
        [2014-04-10 21:37:20] – [RE-Posting] [Facebook – Goodvibes.it] – (Nothing to Repost. – End of Query – Resetting) | Requested Time: 2014-04-10 21:36:51 | Current Time:2014-04-10 21:37:20 | | Last Time:2014-04-10 21:26:51 Next Time – 2014-04-10 21:46:07) | Reposting (Old to New) | Total posts included in reposting: 0 |
        [2014-04-10 21:26:51] – [RE-Poster] [Facebook – Goodvibes.it] – Initialization – First post will be: 2014-04-10 21:36:51
        [2014-04-10 21:26:43] – [Test] [Facebook – Goodvibes.it] – OK – TEST Message Posted

        Thx!

        #182709
        Alessio
        Participant

          Sorry: “…but i can NOT post with autoreposting.”

          #182730
          Alessio
          Participant

            This is my support ticket request #255966. Thank you.

            #183140
            Alessio
            Participant

              I have notice that if i deselect the flag: Repost ONLY previously unautoposted posts
              …it works but post are duplicated:

              [2014-04-11 14:50:38] – [RE-Posting] [Facebook – Goodvibes.it] – OK | Requested Time: 2014-04-11 14:47:23 | Current Time:2014-04-11 14:50:32 | | Previous Time:2014-04-11 13:40:34| Next Shedulled Time – 2014-04-11 15:40:34) | Reposting (Old to New) POST ID:55 | Total posts included in reposting: 166 | Prev Post ID:43 |
              [2014-04-11 14:50:38] – [Posted] [Facebook – Goodvibes.it] – OK – Message Posted | PostID: 55 – La Religione dell’Amore |aj | Post Link
              [2014-04-11 13:40:41] – [RE-Posting] [Facebook – Goodvibes.it] – OK | Requested Time: 2014-04-11 13:35:35 | Current Time:2014-04-11 13:40:34 | | Previous Time:2014-04-11 12:47:23| Next Shedulled Time – 2014-04-11 14:47:23) | Reposting (Old to New) POST ID:43 | Total posts included in reposting: 167 | Prev Post ID:0 |
              [2014-04-11 13:40:41] – [Posted] [Facebook – Goodvibes.it] – OK – Message Posted | PostID: 43 – La locanda |aj | Post Link

              #183199
              Stepen
              Participant

                No matter what I do this never works. I have removed all settings from the database that pertain to this plugin and individual posts in effect starting from a fresh install and the repost feature never works.

                #184461
                Alessio
                Participant

                  New release of wordpress, and new releas of SNAP.

                  Relax. Nothing is change. Nothing works.

                  Compliments.

                  #355338
                  Humberto
                  Participant

                    Does somebody from NextScripts care about all these concerns?

                    #377563
                    SCott Purcell
                    Participant

                      Hi,

                      I’m having the exact same issue. Did any of your fix this problem?

                      Kind regards,
                      Scott

                      #378014
                      Scott Purcell
                      Participant

                        So I think I FINALLY got this to work.

                        I managed to solve the issue I think and it’s working fine now.

                        The issue was that previously I had scheduled way too many reposts with the plugin and there was a huge backup in the cron and scheduling system.

                        When I opened up the server and tried to open the cron line in the wp_options table it took ages to load because the line was so big. That was causing SNAP not to work. To fix this I ran this SQL code and just cleared the backlog.

                        UPDATE wp_options SET option_value = ” WHERE option_name = ‘cron’

                        If you don’t know how to access your server. Go to the c panel with your host > php my admin > click on the wordpress server > click on SQL and past the code above in > click run.

                        See how you go but this fixed my WP-Cron. I’d also followed all the instructions on this page: https://www.nextscripts.com/tutorials/wp-cron-scheduling-tasks-in-wordpress/

                        Cheers,
                        Scott

                      Viewing 10 posts - 1 through 10 (of 10 total)
                      • You must be logged in to reply to this topic.